Case 70528: EULA error message when trying to ship
Incident Report for ShipRush Desktop
Resolved
Users should be able to ship without error again. Please contact support if you are still having difficulty.
Posted 4 months ago. Jan 17, 2019 - 08:01 PST
Monitoring
We believe we have located and resolved the issue, and are continuing to monitor now.
Posted 4 months ago. Jan 17, 2019 - 07:54 PST
Investigating
We're aware of this issue, and are working to get it resolved ASAP. Many customers report that multiple attempts to ship the order will eventually allow a label to print.

We will update here as soon as we have more to share.
Posted 4 months ago. Jan 17, 2019 - 07:24 PST
This incident affected: ShipRush USPS w v2 Postage.