Case 70145 - "Something Went Wrong" / Bad Request errors on My.ShipRush.com
Incident Report for ShipRush Desktop
Resolved
This issue should now be fully resolved. We apologize for the inconvenience.
Posted 5 months ago. Dec 20, 2018 - 10:53 PST
Update
Some users are reporting success loading the site now, after refreshing their browser. We are still investigating.
Posted 5 months ago. Dec 20, 2018 - 10:43 PST
Investigating
We are aware of the server issue and are working to resolve ASAP. We will update this page as soon as we have more to share.
Posted 5 months ago. Dec 20, 2018 - 10:36 PST
This incident affected: ShipRush USPS w v2 Postage and Ecommerce connectivity.