ShipRush Case 74083 - Connectivity errors to ShipRush Web
Incident Report for ShipRush Desktop
Resolved
This issue should now be resolved. Please contact support if you continue having difficulty using ShipRush.
Posted May 28, 2019 - 14:25 PDT
Investigating
We are aware of the issue and are currently investigating. We will update here once more information is available.
Posted May 28, 2019 - 13:01 PDT