Case 74075: Unable to call My.ShipRush. HTTP/1.1 404 Not Found.
Incident Report for ShipRush Desktop
Resolved
This outage has passed. Please reach out to ShipRush support if you continue to have connectivity problems.
Posted May 28, 2019 - 10:29 PDT
Investigating
Some users are getting a 404 Not Found error when trying to rate & Ship USPS, and when refreshing the Order Manager screen. We are investigating this error now. Users report that multiple attempts to rate/ship will eventually allow them to ship. We will post updates here as they become available.
Posted May 28, 2019 - 07:45 PDT
This incident affected: ShipRush USPS w v2 Postage.